I have now enabled all advertising settings on Ezoic. But now the page is very slow. Much slower than my competitor (who also use Ezoic). The Core Web Vitals are not good.

Here is my setting:

Host: Google Cloud,

CDN: Cloudflare,

Theme: Astra,

Ezoic Integration: Plugin,

Nameserver: A German Host,

LEAP: Is activated

Do you have a tip?

Thanks in advance

Many greetings

Paul Changed status to publish June 7, 2022